3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: guile-sqlite3: Fix cross-compilation.

* gnu/packages/patches/guile-sqlite3-fix-cross-compilation.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/guile.scm (guile-sqlite3)[source]: Apply previous patch,
[native-inputs]: add guile.
This commit is contained in:
Mathieu Othacehe 2019-08-18 09:10:58 +02:00
parent 891fd849ce
commit e53bf62e31
No known key found for this signature in database
GPG key ID: 8354763531769CA6
3 changed files with 61 additions and 2 deletions

View file

@ -941,6 +941,7 @@ dist_patch_DATA = \
%D%/packages/patches/guile-relocatable.patch \
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
%D%/packages/patches/guile-emacs-fix-configure.patch \
%D%/packages/patches/guile-sqlite3-fix-cross-compilation.patch \
%D%/packages/patches/gstreamer-buffer-reset-offset.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
%D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \

View file

@ -9,7 +9,7 @@
;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2018 Amirouche <amirouche@hypermove.net>
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
@ -536,11 +536,14 @@ Guile's foreign function interface.")
(sha256
(base32
"1nv8j7wk6b5n4p22szyi8lv8fs31rrzxhzz16gyj8r38c1fyp9qp"))
(file-name (string-append name "-" version "-checkout"))))
(file-name (string-append name "-" version "-checkout"))
(patches
(search-patches "guile-sqlite3-fix-cross-compilation.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("guile" ,guile-2.2)
("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.2)

View file

@ -0,0 +1,55 @@
From a6e9e62a77ecc5012929613e20da23b2636450a5 Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <mathieu.othacehe@parrot.com>
Date: Mon, 25 Mar 2019 11:00:38 +0100
Subject: [PATCH] cross compile
---
build-aux/guile.am | 2 +-
configure.ac | 19 ++++++++++++-------
2 files changed, 13 insertions(+), 8 deletions(-)
diff --git a/build-aux/guile.am b/build-aux/guile.am
index dc1e63f..3126372 100644
--- a/build-aux/guile.am
+++ b/build-aux/guile.am
@@ -16,4 +16,4 @@ EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
SUFFIXES = .scm .go
.scm.go:
- $(AM_V_GEN)$(top_builddir)/env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+ $(AM_V_GEN)$(top_builddir)/env $(GUILE_TOOLS) compile $(GUILE_TARGET) $(GUILE_WARNINGS) -o "$@" "$<"
diff --git a/configure.ac b/configure.ac
index f648fcb..2d34d0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,15 +21,20 @@ PKG_CHECK_MODULES([SQLITE], [sqlite3])
SQLITE_LIBDIR="`"$PKG_CONFIG" sqlite3 --variable libdir`"
AC_SUBST([SQLITE_LIBDIR])
-AC_MSG_CHECKING([whether '$SQLITE_LIBDIR/libsqlite3' is usable])
-GUILE_CHECK([retval],
- [(dynamic-func \"sqlite3_open_v2\"
+if test "$cross_compiling" = "no"; then
+ AC_MSG_CHECKING([whether '$SQLITE_LIBDIR/libsqlite3' is usable])
+ GUILE_CHECK([retval],
+ [(dynamic-func \"sqlite3_open_v2\"
(dynamic-link \"$SQLITE_LIBDIR/libsqlite3\"))])
-if test "$retval" != 0; then
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([failed to load '$SQLITE_LIBDIR/libsqlite3'])
+ if test "$retval" != 0; then
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([failed to load '$SQLITE_LIBDIR/libsqlite3'])
+ else
+ AC_MSG_RESULT([yes])
+ fi
else
- AC_MSG_RESULT([yes])
+ GUILE_TARGET="--target=$host_alias"
+ AC_SUBST([GUILE_TARGET])
fi
AC_CONFIG_FILES([Makefile sqlite3.scm])
--
2.17.1