3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: gcc-vc4: Update to commit 0fe4b83897341742f9df65797474cb0feab4b377.

* gnu/packages/patches/gcc-6-fix-buffer-size.patch: New file.
* gnu/packages/patches/gcc-6-fix-isl-includes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/embedded.scm (gcc-vc4): Update to commit
0fe4b83897341742f9df65797474cb0feab4b377.
[source]: Add the patches from above.
This commit is contained in:
Danny Milosavljevic 2020-11-16 14:54:04 +01:00
parent 455daf46ad
commit f2c6375449
No known key found for this signature in database
GPG key ID: E71A35542C30BAA5
4 changed files with 39 additions and 3 deletions

View file

@ -1013,6 +1013,8 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-4.9-libsanitizer-ustat.patch \ %D%/packages/patches/gcc-4.9-libsanitizer-ustat.patch \
%D%/packages/patches/gcc-libsanitizer-ustat.patch \ %D%/packages/patches/gcc-libsanitizer-ustat.patch \
%D%/packages/patches/gcc-4.9-libsanitizer-mode-size.patch \ %D%/packages/patches/gcc-4.9-libsanitizer-mode-size.patch \
%D%/packages/patches/gcc-6-fix-isl-includes.patch \
%D%/packages/patches/gcc-6-fix-buffer-size.patch \
%D%/packages/patches/gcc-6-libsanitizer-mode-size.patch \ %D%/packages/patches/gcc-6-libsanitizer-mode-size.patch \
%D%/packages/patches/gcc-7-libsanitizer-mode-size.patch \ %D%/packages/patches/gcc-7-libsanitizer-mode-size.patch \
%D%/packages/patches/gcc-libvtv-runpath.patch \ %D%/packages/patches/gcc-libvtv-runpath.patch \

View file

@ -1024,8 +1024,8 @@ the Raspberry Pi chip.")
(home-page "https://github.com/puppeh/vc4-toolchain/")))) (home-page "https://github.com/puppeh/vc4-toolchain/"))))
(define-public gcc-vc4 (define-public gcc-vc4
(let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2") (let ((commit "0fe4b83897341742f9df65797474cb0feab4b377")
(xgcc (cross-gcc "vc4-elf" #:xbinutils binutils-vc4))) (xgcc (cross-gcc "vc4-elf" #:xgcc gcc-6 #:xbinutils binutils-vc4)))
(package (inherit xgcc) (package (inherit xgcc)
(name "gcc-vc4") (name "gcc-vc4")
(source (origin (source (origin
@ -1039,7 +1039,10 @@ the Raspberry Pi chip.")
"-checkout")) "-checkout"))
(sha256 (sha256
(base32 (base32
"13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2")))) "0kvaq4s0assvinmmicwqp07d0wwldcw0fv6f4k13whp3q5909jnr"))
(patches
(search-patches "gcc-6-fix-buffer-size.patch"
"gcc-6-fix-isl-includes.patch"))))
(native-inputs (native-inputs
`(("flex" ,flex) `(("flex" ,flex)
,@(package-native-inputs xgcc))) ,@(package-native-inputs xgcc)))

View file

@ -0,0 +1,15 @@
Fixes a possible buffer overflow. (There are others)
Author: Danny Milosavljevic <dannym@scratchpost.org>
Date: 2020-11-16
--- a/gcc/gimplify.c.orig 2020-10-29 08:45:11.532479774 +0100
+++ b/gcc/gimplify.c 2020-10-29 08:45:49.584637018 +0100
@@ -5229,7 +5229,7 @@
flexibility, split it into separate input and output
operands. */
tree input;
- char buf[10];
+ char buf[12];
/* Turn the in/out constraint into an output constraint. */
char *p = xstrdup (constraint);

View file

@ -0,0 +1,16 @@
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86724
Author: Rainer Jung
Date: 2018-07-29
isl 0.20 stopped including other unused header files in their header files.
Therefore,now it's necessary to include the stuff ourselves.
--- .../gcc/graphite.h 2018-01-03 11:03:58.000000000 +0000
+++ .../gcc/graphite.h 2018-07-29 17:42:55.836121000 +0000
@@ -37,6 +37,8 @@
#include <isl/schedule.h>
#include <isl/ast_build.h>
#include <isl/schedule_node.h>
+#include <isl/id.h>
+#include <isl/space.h>
typedef struct poly_dr *poly_dr_p;