3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00

gnu: racket: fix raco exe with non-minimal Racket

This commit backports an upstream repair for a bug exposed by Guix's
change in Racket 8.2 to make the `racket` package a layered/tethered
installation that chains to the `racket-minimal` package. When using a
layered/tethered installation, the `setup/variant` library would fail to
recognize the default Racet variant (CS, 3M, or CGC), leading to
confusing failures from `raco exe`, `create-embedding-executable`, and
other clients.

For further details, see <https://issues.guix.gnu.org/50118> and
<https://github.com/racket/racket/issues/3969>.

* gnu/packages/patches/racket-minimal-backport-1629887.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/racket.scm (racket-minimal)[source]: Use it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Philip McGrath 2021-09-06 00:59:02 -04:00 committed by Ludovic Courtès
parent 60b42bec84
commit fd22921490
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 32 additions and 1 deletions

View file

@ -1703,6 +1703,7 @@ dist_patch_DATA = \
%D%/packages/patches/ripperx-missing-file.patch \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
%D%/packages/patches/rtags-separate-rct.patch \
%D%/packages/patches/racket-minimal-backport-1629887.patch \
%D%/packages/patches/racket-minimal-sh-via-rktio.patch \
%D%/packages/patches/remake-impure-dirs.patch \
%D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch \

View file

@ -0,0 +1,28 @@
From fb1a6ab205fd63a46669a463931af473e2ac0c87 Mon Sep 17 00:00:00 2001
From: Matthew Flatt <mflatt@racket-lang.org>
Date: Sat, 21 Aug 2021 15:29:59 -0600
Subject: [PATCH] setup/variant: recognize starter executables
Related to #3969
(cherry picked from commit 1629887071fe3cc8fe8af0a7aa0d3912509cb058)
---
racket/collects/setup/variant.rkt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/racket/collects/setup/variant.rkt b/racket/collects/setup/variant.rkt
index 81da6f5701..b23131e481 100644
--- a/racket/collects/setup/variant.rkt
+++ b/racket/collects/setup/variant.rkt
@@ -25,7 +25,7 @@
(and (file-exists? f)
(with-input-from-file f
(lambda ()
- (define m (regexp-match #rx#"bINARy tYPe:..(.)"
+ (define m (regexp-match #rx#"bINARy tYPe:e?..(.)"
(current-input-port)))
(cond
[(not m) '3m]
--
2.30.2

View file

@ -138,7 +138,9 @@
(sha256
"061bhiyjlvazph0dj9i3i3x2q5z53rp8h5cjwg3frjimkr45lncn")
(file-name (git-file-name name version))
(patches (search-patches "racket-minimal-sh-via-rktio.patch"))
(patches (search-patches "racket-minimal-sh-via-rktio.patch"
;; Remove the following in version 8.3:
"racket-minimal-backport-1629887.patch"))
(modules '((guix build utils)))
(snippet
(with-imported-modules '((guix build utils))