3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/cube-nocheck.patch
Dave Love a66408f8c0
gnu: Add cube.
* gnu/packages/profiling.scm(cube): New variable.
* gnu/packages/patches/cube-nocheck.patch: New file.
* gnu/local.mk: Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2017-10-03 17:07:55 +02:00

17 lines
838 B
Diff

Unconditionally disable network check for new versions (from Fedora).
diff -u /home/dlove/rpmbuild/BUILD/cube-4.3.4/src/GUI-qt/display/VersionCheckWidget.cpp\~ /home/dlove/rpmbuild/BUILD/cube-4.3.4/src/GUI-qt/display/VersionCheckWidget.cpp
--- cube-4.3.4/src/GUI-qt/display/VersionCheckWidget.cpp~ 2016-04-03 00:05:37.942066948 +0100
+++ cube-4.3.4/src/GUI-qt/display/VersionCheckWidget.cpp 2016-05-06 17:16:31.648143908 +0100
@@ -52,7 +52,8 @@
url = QUrl( UPDATE_CHECK_URL );
download = NULL;
update_Available = false;
- bool no_http = env_str2bool( getenv( "CUBE_DISABLE_HTTP_DOCS" ) );
+ // bool no_http = env_str2bool( getenv( "CUBE_DISABLE_HTTP_DOCS" ) );
+ bool no_http = true;
if ( !no_http )
{
updateDescription = tr( "Check for update is not performed yet." );