3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/fastcap-mulSetup.patch
Federico Beffa 930945015c gnu: Add fastcap.
* gnu/packages/engineering.scm (fastcap): New variable.
  (broken-tarball-fetch): New function.  Suggested by Ludovic Courtès
  <ludo@gnu.org>.
* gnu/packages/patches/fastcap-mulGlobal.patch,
  gnu/packages/patches/fastcap-mulSetup.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
2015-08-01 12:29:37 +02:00

20 lines
514 B
Diff

Add forward declarations.
--- fastcap/src/mulSetup.c.orig 2015-07-22 13:55:21.592119775 +0200
+++ fastcap/src/mulSetup.c 2015-07-22 14:08:50.157688209 +0200
@@ -35,6 +35,14 @@
#include "mulGlobal.h"
+static getnbrs(ssystem*);
+static linkcubes(ssystem*);
+static setMaxq(ssystem*);
+static getAllInter(ssystem*);
+static set_vector_masks(ssystem*);
+static indexkid(ssystem*, cube*, int*, int*);
+static int placeq(int, ssystem*, charge*);
+
cube *cstack[1024]; /* Stack used in several routines. */
/*