3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/libusb-for-axoloti.patch
Ricardo Wurmus 6623bd826b
gnu: libusb-for-axoloti: Adjust patch.
* gnu/packages/patches/libusb-for-axoloti.patch: Adjust patch for use with
current version of libusb.
2018-05-23 15:23:01 +02:00

17 lines
395 B
Diff

diff --git a/libusb/descriptor.c b/libusb/descriptor.c
index 74d6de5..0b0e314 100644
--- a/libusb/descriptor.c
+++ b/libusb/descriptor.c
@@ -1174,7 +1174,7 @@ int API_EXPORTED libusb_get_string_descriptor_ascii(libusb_device_handle *dev_ha
return LIBUSB_ERROR_IO;
if (tbuf[0] > r)
- return LIBUSB_ERROR_IO;
+ tbuf[0] = r;
di = 0;
for (si = 2; si < tbuf[0]; si += 2) {
--
2.17.0