3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch
Miguel Ángel Arruga Vivas af561664b8
gnu: seahorse: Update to 3.30.1.1.
* gnu/packages/gnome.scm (seahorse)[version]: Update version number.
[origin]: Update hash.  Add patch needed for compilation with our
version of libsecret (0.19.1).
[inputs]: Add avahi dependency.
[native-inputs]: Add vala dependency.  Use gettext-minimal instead of
intltool, as only xgettext is used.
* gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2019-10-22 18:32:52 +02:00

32 lines
1.4 KiB
Diff

Patch from <https://gitlab.gnome.org/GNOME/seahorse/commit/d9db29db567012b7c72e85e1be1fbf55fcc9b667>.
From d9db29db567012b7c72e85e1be1fbf55fcc9b667 Mon Sep 17 00:00:00 2001
From: Niels De Graef <nielsdegraef@gmail.com>
Date: Sat, 11 May 2019 09:02:34 +0200
Subject: [PATCH] gkr: Use 0 on empty flags
A Flags-type variable without any flag set can be replaced with 0, so
this is a safe thing to do. It also prevents us from having to deal with
the accidental API break in libsecret (see
https://gitlab.gnome.org/GNOME/libsecret/merge_requests/19)
---
gkr/gkr-keyring-add.vala | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/gkr/gkr-keyring-add.vala b/gkr/gkr-keyring-add.vala
index 4e92a520..f60c9a22 100644
--- a/gkr/gkr-keyring-add.vala
+++ b/gkr/gkr-keyring-add.vala
@@ -41,8 +41,7 @@ public class Seahorse.Gkr.KeyringAdd : Gtk.Dialog {
var cancellable = Dialog.begin_request(this);
var service = Backend.instance().service;
- Secret.Collection.create.begin(service, this.name_entry.text, null,
- Secret.CollectionCreateFlags.COLLECTION_CREATE_NONE,
+ Secret.Collection.create.begin(service, this.name_entry.text, null, 0,
cancellable, (obj, res) => {
/* Clear the operation without cancelling it since it is complete */
Dialog.complete_request(this, false);
--
2.23.0