3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/akonadi-not-relocatable.patch
Brendan Tildesley 298b349a05
gnu: KDE PIM: Update all packages to 21.12.3.
* gnu/packages/kde-pim.scm (KDE PIM): Update to 21.12.3.

(akonadi, akonadi-calendar, akonadi-contacts, akonadi-mime,
akonadi-notes, akonadi-search, kaddressbook, kalarmcal,
kcalendarsupport, kcalutils, kdepim-runtime, keventviews, kgpg,
kidentitymanagement, kimap, kincidenceeditor, kldap, kleopatra, kmail,
kmailcommon, kmailimporter, kmailtransport, kmbox, kmessagelib, kmime,
knotes, kontactinterface, korganizer, kpeoplevcard, kpimcommon,
kpimtextedit, ksmtp, ktnef, libgravatar, libkdepim, libkgapi, libkleo,
libksieve): Update to 21.12.3.
(kblog): Update to 20.04.3.

* gnu/packages/patches/akonadi-not-relocatable.patch
* gnu/packages/patches/akonadi-paths.patch
* gnu/packages/patches/akonadi-timestamps.patch
Fix patches to apply to latest code.

(akonadi-calendar): [inputs]: Add new dependencies.

(akonadi-contacts): [inputs]: Add new dependencies.

(akonadi-search): [arguments]: Disable failing tests.

(kcalendarsupport): [inputs]: Add new dependency, remove obsolete kdepim-apps-lib.

(libksieve): [arguments]: Enable test that works now.
* gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch: Fix patch.

(kaddressbook): [inputs]: Remove obsolete kdepim-apps-libs.
Move kdocstools to native-inputs.

(kmessagelib): [inputs]: Remove obsolete kdepim-appslibs, add kguiaddons.
[arguments]: Fix findind header file.

(kmailimporter): [inputs]: Add new dependencies.

(kmailtransport): [inputs]: Add qtkeychain.

(knotes): [inputs]: Move kdocstools to native-inputs.

(kincidenceeditor): [inputs]: Add new dependencies. Remove obsolete kdepim-apps-libs
[arguments]: Disable failing test.

(kldap): [inputs]: Add qtkeychain.

(kgpg)[arguments]: Disable failing tests.

(libkleo): [propagated-inputs]: Propagate gpgme, qgpgme.
[arguments]: Disable failing tests.

(kdepim-runtime): [inputs]: Add new dependencies grantlee, grantleetheme, kcmutils, kldap,
libkdepim, qtkeychain
[arguments]: Enable all the tests that pass.
We need to use the old hack instead of search-input-directory to
workaround a mysterious include error.

(kdepim-apps-lib): Remove obsolete package.

(kmail): [origin]: Remove patch. Don't think it is needed anymore.
[inputs]: Add new dependencies, delete obsolete kdepim-apps-libs and
duplicate kmime.
[arguments]: Disable failing tests.
* gnu/packages/patches/kmail-Fix-missing-link-libraries.patch: Delete file.
* gnu/local.mk: Remove reference to patch.

(kmailcommon): [inputs]: Add new dependencies.

Signed-off-by: Marius Bakke <marius@gnu.org>
2022-09-01 17:23:59 +02:00

44 lines
1.5 KiB
Diff

From 4b90a0bd4411a66bbe6ecf85ce89a60a58bee969 Mon Sep 17 00:00:00 2001
From: Thomas Tuegel <ttuegel@mailbox.org>
Date: Sun, 25 Apr 2021 08:01:21 -0500
Subject: [PATCH 3/3] akonadi revert make relocatable
---
CMakeLists.txt | 3 ---
KF5AkonadiConfig.cmake.in | 6 +++---
2 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e8cc81..63161b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -368,9 +368,6 @@ configure_package_config_file(
"${CMAKE_CURRENT_SOURCE_DIR}/KF5AkonadiConfig.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/KF5AkonadiConfig.cmake"
INSTALL_DESTINATION ${CMAKECONFIG_INSTALL_DIR}
- PATH_VARS AKONADI_DBUS_INTERFACES_INSTALL_DIR
- AKONADI_INCLUDE_DIR
- KF5Akonadi_DATA_DIR
)
install(FILES
diff --git a/KF5AkonadiConfig.cmake.in b/KF5AkonadiConfig.cmake.in
index bcf7320..1574319 100644
--- a/KF5AkonadiConfig.cmake.in
+++ b/KF5AkonadiConfig.cmake.in
@@ -1,10 +1,10 @@
@PACKAGE_INIT@
-set_and_check(AKONADI_DBUS_INTERFACES_DIR "@PACKAGE_AKONADI_DBUS_INTERFACES_INSTALL_DIR@")
-set_and_check(AKONADI_INCLUDE_DIR "@PACKAGE_AKONADI_INCLUDE_DIR@")
+set_and_check(AKONADI_DBUS_INTERFACES_DIR "@AKONADI_DBUS_INTERFACES_INSTALL_DIR@")
+set_and_check(AKONADI_INCLUDE_DIR "@AKONADI_INCLUDE_DIR@")
# The directory where akonadi-xml.xsd and kcfg2dbus.xsl are installed
-set(KF5Akonadi_DATA_DIR "@PACKAGE_KF5Akonadi_DATA_DIR@")
+set(KF5Akonadi_DATA_DIR "@KF5Akonadi_DATA_DIR@")
# set the directories
if(NOT AKONADI_INSTALL_DIR)
--
2.31.1