3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch
Tom Fitzhenry 6ba74ab29c
gnu: Remove texlive's dependence on ruby-rspec and ruby-byebug.
Motivation: Break the dependency chain from guix to mariadb.

Prior to this patch:

$ guix graph --path guix mariadb
guix@1.3.0-27.598f728
po4a@0.63
texlive-tiny@59745
texlive-latex-base@59745
texlive-hyphen-afrikaans@59745
ruby-hydra@0.0-0.5abfa37
ruby-byebug@11.1.3
ruby-rubocop@1.10.0
ruby-parallel@1.21.0
ruby-mysql2@0.5.2
mariadb@10.5.12

As of this patch:

$ ./pre-inst-env guix graph --path guix mariadb
guix graph: error: no path from 'guix@1.3.0-27.598f728' to 'mariadb@10.5.12'

* gnu/local.mk (dist_patch_DATA): Add texlive-hyph-utf8-no-byebug.patch.
* gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch: New file.
* gnu/packages/tex.scm (hyph-utf8-scripts): Add patch.
(texlive-hyphen-package): Depend on ruby-hydra-minimal.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2022-08-08 17:26:18 +02:00

13 lines
384 B
Diff

Description: Avoid dependency on byebug to reduce package closure
significantly, see https://issues.guix.gnu.org/55997
diff --git a/lib/tex/hyphen/language.rb b/lib/tex/hyphen/language.rb
index 12831417..df6daa39 100644
--- a/lib/tex/hyphen/language.rb
+++ b/lib/tex/hyphen/language.rb
@@ -1,6 +1,5 @@
require 'yaml'
require 'hydra'
-require 'byebug'
require_relative 'path'