3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/python-3-deterministic-build-info.patch
Ludovic Courtès 9820a6d4a0 gnu: python: Make 'sys.version' deterministic.
* gnu/packages/patches/python-2-deterministic-build-info.patch,
  gnu/packages/patches/python-3-deterministic-build-info.patch: New
  files.
* gnu/packages/python.scm (python-2, python): Use them.
* gnu-system.am (dist_patch_DATA): Add them.
2015-11-29 22:59:28 +01:00

18 lines
440 B
Diff

Always provide the same date and time in 'Py_GetBuildInfo'.
This is the information shown at the REPL and in 'sys.version'.
We cannot pass it in CPPFLAGS due to whitespace in the DATE string.
--- Modules/getbuildinfo.c
+++ Modules/getbuildinfo.c
@@ -4,6 +4,10 @@
#include <stdio.h>
#endif
+/* Deterministic date and time. */
+#define DATE "Jan 1 1970"
+#define TIME "00:00:01"
+
#ifndef DATE
#ifdef __DATE__
#define DATE __DATE__