3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/hdf5-config-date.patch
Eric Bavier b8d9c93bde gnu: hdf5: Have configure honor SOURCE_DATE_EPOCH.
* gnu/packages/patches/hdf5-config-date.patch: New patch.
* gnu/packages/maths.scm (hdf5)[source]: Use it.
* gnu-system.am (dist_patch_DATA): Add it.
2016-05-12 19:59:52 +00:00

22 lines
609 B
Diff

Honor SOURCE_DATE_EPOCH when exporting configuration date.
Autoconf-level patch submitted upstream on Wed Apr 13 17:03:23 UTC 2016
--- a/configure
+++ b/configure
@@ -27737,7 +28573,14 @@
## Configuration date
- CONFIG_DATE="`date`"
+ CONFIG_DATE="`date -u`"
+if test -n "$SOURCE_DATE_EPOCH"; then
+ CONFIG_DATE=`date -u -d "@$SOURCE_DATE_EPOCH" 2>/dev/null \
+ || date -u -r "$SOURCE_DATE_EPOCH" 2>/dev/null`
+ if test -z "$CONFIG_DATE"; then
+ as_fn_error $? "malformed SOURCE_DATE_EPOCH" "$LINENO" 5
+ fi
+fi
## User doing the configuration
CONFIG_USER="`whoami`@`hostname`"