3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/libmp4v2-c++11.patch
Marius Bakke 995c30d0d6
gnu: libmp4v2: Fix build with C++11.
* gnu/packages/patches/libmp4v2-c++11.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/video.scm (libmp4v2)[source](patches): New field.
2019-07-18 16:31:14 +02:00

15 lines
659 B
Diff

Avoid a type mismatch that shows up in C++11.
Taken from <https://bugs.debian.org/853560>.
--- a/src/rtphint.cpp 2012-05-20 16:11:53.000000000 -0600
+++ b/src/rtphint.cpp 2017-05-16 10:25:26.930705191 -0600
@@ -339,7 +339,7 @@
pSlash = strchr(pSlash, '/');
if (pSlash != NULL) {
pSlash++;
- if (pSlash != '\0') {
+ if (*pSlash != '\0') {
length = (uint32_t)strlen(pRtpMap) - (pSlash - pRtpMap);
*ppEncodingParams = (char *)MP4Calloc(length + 1);
strncpy(*ppEncodingParams, pSlash, length);