3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/python-2.7-adjust-tests.patch
Marius Bakke 603a64920f
gnu: python@2: Update to 2.7.14.
* gnu/packages/python.scm (python-2.7): Update to 2.7.14.
[source]: Add patch to skip two new tests.  Delete upstreamed patch.
* gnu/packages/patches/python-2.7-adjust-tests.patch: New file.
* gnu/packages/patches/python-2.7-getentropy-on-old-kernels.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
2017-10-19 00:16:49 +02:00

23 lines
808 B
Diff

SIGINT is ignored in the Guix build environment.
--- a/Lib/test/test_regrtest.py
+++ b/Lib/test/test_regrtest.py
@@ -399,6 +399,8 @@
output = self.run_tests('--fromfile', filename)
self.check_executed_tests(output, tests)
+ @unittest.skipIf(True,
+ "KeyboardInterrupts do not work in the build environment")
def test_interrupted(self):
code = TEST_INTERRUPTED
test = self.create_test('sigint', code=code)
@@ -416,6 +418,8 @@
% (self.TESTNAME_REGEX, len(tests)))
self.check_line(output, regex)
+ @unittest.skipIf(True,
+ "KeyboardInterrupts do not work in the build environment")
def test_slow_interrupted(self):
# Issue #25373: test --slowest with an interrupted test
code = TEST_INTERRUPTED