mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
582b1f626f
* gnu/packages/graph.scm (python-louvain)[source]: Add patch. * gnu/packages/patches/python-louvain-fix-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
15 lines
677 B
Diff
15 lines
677 B
Diff
https://github.com/taynaud/python-louvain/commit/638804ae636dc65306900ef6518ca0a1c9202566.diff
|
|
|
|
diff --git a/test_community.py b/test_community.py
|
|
index 1ee1976..566a4b1 100644
|
|
--- a/test_community.py
|
|
+++ b/test_community.py
|
|
@@ -203,7 +203,7 @@ def test_karate(self):
|
|
self.assertAlmostEqual(co.modularity(part, graph),
|
|
co.modularity(part_weight,
|
|
graph,
|
|
- "test_weight"), places=2)
|
|
+ "test_weight"), places=1)
|
|
|
|
part_res_low = co.best_partition(graph, resolution=0.1)
|
|
self.assertTrue(
|