3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch
Hilton Chain adc3b7d31d
gnu: webrtc-for-telegram-desktop: Update to 621f3da5.
* gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Register it here.
* gnu/packages/telegram.scm (webrtc-for-telegram-desktop): Update to 621f3da5.
[patches]: Add webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch.
[snippet]: Unbundle libvpx and openh264.
[native-inputs]: Remove perl.
[inputs]: Replace pipewire with pipewire-0.3.
Add abseil-cpp-cxxstd17, libdrm, libglvnd, libvpx, libxfixes, mesa, openh264.
Remove alsa-lib, libx11 and pulseaudio.
[arguments]<#:phases>: Adjust accordingly.
[license]: Likewise.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2022-09-28 20:22:38 +02:00

21 lines
666 B
Diff

From 86d2bcd7afb8706663d29e30f65863de5a626142 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 15 May 2022 12:47:41 +0200
Subject: [PATCH] fix(h265_pps_parser): fix missing cstdint include
---
src/common_video/h265/h265_pps_parser.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/common_video/h265/h265_pps_parser.h b/src/common_video/h265/h265_pps_parser.h
index 28c95ea9..c180b1b9 100644
--- a/src/common_video/h265/h265_pps_parser.h
+++ b/src/common_video/h265/h265_pps_parser.h
@@ -12,6 +12,7 @@
#define COMMON_VIDEO_H265_PPS_PARSER_H_
#include "absl/types/optional.h"
+#include <cstdint>
namespace rtc {
class BitBuffer;