3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/bsd-games-stdio.h.patch
Vitaliy Shatrov 95024494f3
gnu: Add bsd-games.
* gnu/packages/games.scm (bsd-games): New variable.

New patches, taken from Arch and Debian:
* gnu/packages/patches/bsd-games-2.17-64bit.patch
* gnu/packages/patches/bsd-games-bad-ntohl-cast.patch
* gnu/packages/patches/bsd-games-gamescreen.h.patch
* gnu/packages/patches/bsd-games-getline.patch
* gnu/packages/patches/bsd-games-null-check.patch
* gnu/packages/patches/bsd-games-number.c-and-test.patch
* gnu/packages/patches/bsd-games-prevent-name-collisions.patch
* gnu/packages/patches/bsd-games-stdio.h.patch

New patches with our customizations (configure-config built after Arch's):
* gnu/packages/patches/bsd-games-add-configure-config.patch
* gnu/packages/patches/bsd-games-add-wrapper.patch
* gnu/packages/patches/bsd-games-dont-install-empty-files.patch

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
2020-11-04 15:15:47 +01:00

15 lines
340 B
Diff

diff -ru a/include/stdio.h b/include/stdio.h
--- a/include/stdio.h 2000-08-04 10:24:39.000000000 +1000
+++ b/include/stdio.h 2005-06-18 14:26:35.000000000 +1000
@@ -34,6 +34,10 @@
#include <bsd-games.h>
#include_next <stdio.h>
+__BEGIN_DECLS
+
#ifndef HAVE_fgetln
extern char *fgetln(FILE *stream, size_t *len);
#endif
+
+__END_DECLS