3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/clisp-remove-failing-test.patch
Efraim Flashner f473b8f1f7
gnu: clisp: Update to 2.49-60.
* gnu/packages/lisp.scm (clisp): Update to 2.49-60.
[source]: Download mercurial repository, apply patch.
[inputs]: Replace readline@6.2 with readline, add ncurses.
[arguments]: Add multiple configure flags. Remove build phase to build
in "src" directory. Remove more uses of a timestamp.
2017-10-04 09:29:24 +03:00

44 lines
1.7 KiB
Diff

This test doesn't ever complete or timeout
---
tests/socket.tst | 24 ------------------------
1 file changed, 24 deletions(-)
diff --git a/tests/socket.tst b/tests/socket.tst
index 93c6310..1d976ff 100644
--- a/tests/socket.tst
+++ b/tests/socket.tst
@@ -551,30 +551,6 @@ T
interfaces))
("0.0.0.0" "127.0.0.1" "0.0.0.0" "127.0.0.1")
-(multiple-value-bind (run args) (cmd-args)
- (let ((se (socket:socket-server)))
- (ext:run-program run :arguments (append args (list "-q" "-q" "-x" (format nil "(close (socket:socket-connect ~D))" (socket:socket-server-port se))))
- :wait nil :input nil :output nil)
- (unwind-protect
- (with-open-stream (so (socket:socket-accept se))
- (list
- (socket:socket-status so)
- (write-line "foo" so)
- (socket:socket-status so)
- #+macos (handler-case (read-char so)
- (end-of-file (c)
- (princ 'read-char) (princ-error c) t))
- #-macos (check-os-error (read-char so) (:ECONNRESET 104))
- (null (member (socket:socket-status so) '(:EOF :APPEND)))
- #+macos (string= (write-line "bar" so) "bar")
- #-macos (check-os-error (write-line "bar" so) (:EPIPE 32))
- (null (member (socket:socket-status so) '(:EOF :APPEND)))
- (handler-case (read-char so)
- (end-of-file (c)
- (princ 'read-char) (princ-error c) 'end-of-file))))
- (socket:socket-server-close se))))
-(:OUTPUT "foo" :OUTPUT T NIL T NIL END-OF-FILE)
-
;; https://sourceforge.net/p/clisp/feature-requests/46/
(check-os-error (socket:socket-connect 0)
#-(or win32 macos) (:ECONNREFUSED 111)
--