3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/gmp-faulty-test.patch
Ludovic Courtès 42e735dfc7 gnu: gmp: Skip unreliable test.
* gnu/packages/patches/gmp-faulty-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/multiprecision.scm (gmp)[source]: Use it.
2015-10-06 15:18:44 +02:00

12 lines
302 B
Diff

Skip a test that randomly fails on ARMv7: <http://bugs.gnu.org/21620>.
--- a/tests/mpz/reuse.c
+++ b/tests/mpz/reuse.c
@@ -213,6 +213,7 @@ main (int argc, char **argv)
mpz_t bs;
unsigned long bsi, size_range;
+ exit (77); /* skip */
tests_start ();
TESTS_REPS (reps, argv, argc);