3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/kinit-kdeinit-extra_libs.patch
Marius Bakke 9d3965edca
gnu: KDE Frameworks: Update to 5.70.
* gnu/packages/patches/kinit-kdeinit-extra_libs.patch: Adjust for upstream changes.
* gnu/packages/kde-frameworks.scm (extra-cmake-modules, attica, bluez-qt,
breeze-icons, kapidox, karchive, kcalendarcore, kcodecs, kconfig, kcoreaddons,
kdbusaddons, kdnssd, kguiaddons, kholidays, ki18n, kidletime, kirigami,
kitemmodels, kitemviews, kplotting, ksyntaxhighlighting, kwidgetsaddons,
kwindowsystem, modemmanager-qt, networkmanager-qt, oxygen-icons, prison,
qqc2-desktop-style, solid, sonnet, threadweaver, kactivities, kauth,
kcompletion, kcontacts, kcrash, kdoctools, kfilemetadata, kimageformats,
kjobwidgets, knotifications, kpackage, kpty, kunitconversion, syndication,
baloo, kactivities-stats, kbookmarks, kcmutils, kconfigwidgets, kdeclarative,
kded, kdesignerplugin, kdesu, kdewebkit, kemoticons, kglobalaccel,
kiconthemes, kinit, knewstuff, knotifyconfig ,kparts, kpeople, krunner,
kservice, ktextwidgets, kwallet, kxmlgui, kxmlrpcclient, purpose,
kde-frameworkintegration, kdelibs4support, khtml, kjs, kjsembed, kmediaplayer,
kross): Update to 5.70.0.
(kwayland)[inputs]: Add QTWAYLAND.
(kparts)[arguments]: New field.
(kinit)[inputs]: Add KDBUSADDONS.
(kcmutils)[inputs]: Add KGUIADDONS.
(krunner)[native-inputs]: Add DBUS.
[arguments]: Run tests with "dbus-launch".
(baloo)[arguments]: Remove broken test substitution.  Disable one other test.
(ktexteditor, plasma-framework): Update to 5.70.1.
(kio): Likewise.
[inputs]: Move KWINDOWSYSTEM ...
[propagated-inputs]: ... here.
2020-05-26 22:32:56 +02:00

54 lines
1.8 KiB
Diff

Search the "extra libs" in GUIX_KF5INIT_LIB_PATH (which basically is a
collection of all /lib directories). We can not hard-code the full path to the
libsKF5Plasam, since adding palse-workspace
Adopted from NixOS
pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
===================================================================
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
@@ -96,9 +96,9 @@
"libKF5Parts.5.dylib",
"libKF5Plasma.5.dylib"
#else
- "libKF5KIOCore.so.5",
- "libKF5Parts.so.5",
- "libKF5Plasma.so.5"
+ "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
+ "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
+ "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
#endif
};
#endif
@@ -1533,20 +1531,6 @@ static int initXconnection()
}
#endif
-#ifndef Q_OS_OSX
-// Find a shared lib in the lib dir, e.g. libkio.so.
-// Completely unrelated to plugins.
-static QString findSharedLib(const QString &lib)
-{
- QString path = QFile::decodeName(CMAKE_INSTALL_PREFIX "/" LIB_INSTALL_DIR "/") + lib;
- if (QFile::exists(path)) {
- return path;
- }
- // We could also look in LD_LIBRARY_PATH, but really, who installs the main libs in different prefixes?
- return QString();
-}
-#endif
-
extern "C" {
static void secondary_child_handler(int)
@@ -1673,7 +1673,7 @@
#if defined(Q_OS_UNIX) && !defined(Q_OS_OSX)
if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) {
for (const char *extra_lib : extra_libs) {
- const QString extra = findSharedLib(QString::fromLatin1(extra_lib));
+ const QString extra = QString::fromLatin1(extra_lib);
if (!extra.isEmpty()) {
QLibrary l(extra);
l.setLoadHints(QLibrary::ExportExternalSymbolsHint);