3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/libofa-ftbfs-2.diff
Raghav Gururajan 38375ce952
gnu: Add libofa.
* gnu/packages/audio.scm (libofa): New variable.
* gnu/packages/patches/libofa-ftbfs-1.diff: New file.
* gnu/packages/patches/libofa-curl.diff: New file.
* gnu/packages/patches/libofa-ftbfs-2.diff: New file.
* gnu/local.mk (dist_patch_DATA): Add them.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
2020-08-18 22:56:32 +02:00

28 lines
804 B
Diff

Description: ftbfs with GCC-4.7. (Closes: #667250)
Author: Matthias Klose <doko@debian.org>
Last-Update: 2012-04-17
Index: libofa-0.9.3/examples/uselame.cpp
===================================================================
--- libofa-0.9.3.orig/examples/uselame.cpp
+++ libofa-0.9.3/examples/uselame.cpp
@@ -11,6 +11,7 @@
#include "windows.h"
#else
#include <sys/wait.h>
+#include <unistd.h>
#endif
AudioData *loadWaveFile(char *file);
Index: libofa-0.9.3/examples/wavefile.cpp
===================================================================
--- libofa-0.9.3.orig/examples/wavefile.cpp
+++ libofa-0.9.3/examples/wavefile.cpp
@@ -11,6 +11,7 @@
#include "io.h"
#endif
#include <fcntl.h>
+#include <unistd.h>
static bool readBytes(int fd, unsigned char *buf, int size) {
int ct = 0;