3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/libutils-remove-damaging-includes.patch
Danny Milosavljevic be906ad16e
gnu: Add android-libutils.
* gnu/packages/patches/libutils-add-includes.patch: New file.
* gnu/packages/patches/libutils-remove-damaging-includes.patch: New file.
* gnu/packages/android.scm (android-platform-system-core): Use them.
(android-libutils): New variable.
* gnu/local.mk: Add them.
2018-05-09 22:32:36 +02:00

22 lines
603 B
Diff

--- a/include/utils/StrongPointer.h 2018-04-25 18:42:34.321003602 +0200
+++ b/include/utils/StrongPointer.h 2018-04-25 18:42:42.180912201 +0200
@@ -17,8 +17,6 @@
#ifndef ANDROID_STRONG_POINTER_H
#define ANDROID_STRONG_POINTER_H
-#include <cutils/atomic.h>
-
#include <stdint.h>
#include <sys/types.h>
#include <stdlib.h>
--- a/libutils/Trace.cpp 2018-04-25 20:41:48.775049786 +0200
+++ b/libutils/Trace.cpp 2018-04-25 20:42:13.674744182 +0200
@@ -21,5 +21,7 @@
static void traceInit()
{
+#if defined(__ANDROID__)
::android::add_sysprop_change_callback(atrace_update_tags, 0);
+#endif
}