3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/python-memcached-syntax-warnings.patch
Tanguy Le Carrour 8d5c55b2e8
gnu: python-memcached: Add patch to fix syntax warnings.
* gnu/packages/patches/python-memcached-syntax-warnings.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python-xyz.scm (python-memcached)[source]: Add it.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
2020-06-16 23:18:26 +03:00

25 lines
701 B
Diff

Problem reported upstream:
https://github.com/linsomniac/python-memcached/issues/176
---
memcache.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/memcache.py b/memcache.py
index 05b6657..b935681 100644
--- a/memcache.py
+++ b/memcache.py
@@ -1300,8 +1300,8 @@ class Client(threading.local):
key = key[1]
if key is None:
raise Client.MemcachedKeyNoneError("Key is None")
- if key is '':
- if key_extra_len is 0:
+ if key == '':
+ if key_extra_len == 0:
raise Client.MemcachedKeyNoneError("Key is empty")
# key is empty but there is some other component to key
--
2.26.2