mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
d7e7494bc4
* gnu/packages/admin.scm (fail2ban): New variable. * gnu/packages/patches/fail2ban-0.11.2_CVE-2021-32749.patch, gnu/packages/patches/fail2ban-0.11.2_fix-setuptools-drop-2to3.patch, gnu/packages/patches/fail2ban-0.11.2_fix-test-suite.patch, gnu/packages/patches/fail2ban-paths-guix-conf.patch, gnu/packages/patches/fail2ban-python310-server-action.patch, gnu/packages/patches/fail2ban-python310-server-actions.patch, gnu/packages/patches/fail2ban-python310-server-jails.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
27 lines
902 B
Diff
27 lines
902 B
Diff
From 2b6bb2c1bed8f7009631e8f8c306fa3160324a49 Mon Sep 17 00:00:00 2001
|
|
From: "Sergey G. Brester" <serg.brester@sebres.de>
|
|
Date: Mon, 8 Feb 2021 17:19:24 +0100
|
|
Subject: [PATCH] follow bpo-37324: :ref:`collections-abstract-base-classes`
|
|
moved to the :mod:`collections.abc` module
|
|
|
|
(since 3.10-alpha.5 `MutableMapping` is missing in collections module)
|
|
---
|
|
fail2ban/server/action.py | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/fail2ban/server/action.py b/fail2ban/server/action.py
|
|
index 3bc48fe046..f0f1e6f59a 100644
|
|
--- a/fail2ban/server/action.py
|
|
+++ b/fail2ban/server/action.py
|
|
@@ -30,7 +30,10 @@
|
|
import threading
|
|
import time
|
|
from abc import ABCMeta
|
|
-from collections import MutableMapping
|
|
+try:
|
|
+ from collections.abc import MutableMapping
|
|
+except ImportError:
|
|
+ from collections import MutableMapping
|
|
|
|
from .failregex import mapTag2Opt
|
|
from .ipdns import DNSUtils
|