mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
bff70d93d2
Reported by sirgazil on #guix. * gnu/packages/patches/python-jedi-sort-project-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-xyz.scm (python-jedi)[source](patches): Add it. [arguments]: Run tests more verbosely while at it.
18 lines
763 B
Diff
18 lines
763 B
Diff
Sort the result of file system traversal to avoid test failure on different
|
|
file systems.
|
|
|
|
Taken from upstream:
|
|
https://github.com/davidhalter/jedi/commit/7ff76bb7d0d94514e17cd1647f4ffaf533dd55f5
|
|
|
|
diff --git a/test/test_api/test_project.py b/test/test_api/test_project.py
|
|
--- a/test/test_api/test_project.py
|
|
+++ b/test/test_api/test_project.py
|
|
@@ -135,7 +135,7 @@ def test_search(string, full_names, kwargs, skip_pre_python36):
|
|
defs = project.complete_search(string, **kwargs)
|
|
else:
|
|
defs = project.search(string, **kwargs)
|
|
- assert [('stub:' if d.is_stub() else '') + d.full_name for d in defs] == full_names
|
|
+ assert sorted([('stub:' if d.is_stub() else '') + d.full_name for d in defs]) == full_names
|
|
|
|
|
|
@pytest.mark.parametrize(
|