3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/python-configobj-setuptools.patch
Leo Famulari 99fffa8ae0 gnu: Add python-configobj.
* gnu/packages/python.scm (python-configobj, python2-configobj): New
  variables.
* gnu/packages/patches/python-configobj-setuptools.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
2015-12-05 09:44:37 -05:00

31 lines
715 B
Diff

From 16fbc38f13e435b4e3e1a37d706e64e05bad4691 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Tue, 10 Nov 2015 23:09:24 -0500
Subject: [PATCH] patch build to use setuptools
---
setup.py | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index c6d57a6..27bf260 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,12 @@
# http://opensource.org/licenses/BSD-3-Clause
import os
import sys
-from distutils.core import setup
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
# a simple import wouldn't work if we moved towards a package with __init__
from _version import __version__
--
2.6.2