3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/pango-skip-libthai-test.patch
Marius Bakke 869b63cb93
gnu: pango: Update to 1.44.7.
* gnu/packages/patches/pango-skip-libthai-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/gtk.scm (pango): Update to 1.44.7.
[source](patches): New field.
[build-system]: Switch to MESON-BUILD-SYSTEM.
[arguments]: Disable tests that require the Cantarell font.
[inputs]: Move LIBXFT ...
[propagated-inputs]: ... here.
(pango-1.42): New public variable.
* gnu/packages/gnome.scm (librsvg)[inputs]: Change from PANGO to PANGO-1.42.
2020-01-11 18:59:23 +01:00

24 lines
909 B
Diff

Skip Thai character test when libthai is unavailable.
Taken from upstream bug tracker:
https://gitlab.gnome.org/GNOME/pango/merge_requests/161
https://gitlab.gnome.org/GNOME/pango/commit/b73284747ac937e31dc9191f84ed6e24284c88ee
diff --git a/tests/test-break.c b/tests/test-break.c
index 8549b678bba69360d07dce3af21d915412f20d51..47fa3009165e19a331aa04a0df4351ae2323933b 100644
--- a/tests/test-break.c
+++ b/tests/test-break.c
@@ -305,6 +305,12 @@ main (int argc, char *argv[])
if (!strstr (name, "break"))
continue;
+#ifndef HAVE_LIBTHAI
+ /* four.break involves Thai, so only test it when we have libthai */
+ if (strstr (name, "four.break"))
+ continue;
+#endif
+
path = g_strdup_printf ("/break/%s", name);
g_test_add_data_func_full (path, g_test_build_filename (G_TEST_DIST, "breaks", name, NULL),
test_break, g_free);