3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/shishi-fix-libgcrypt-detection.patch
Leo Famulari 1abc08a8f4
gnu: shishi: Build with latest libgcrypt.
* gnu/packages/patches/shishi-fix-libgcrypt-detection.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/kerberos.scm (shishi)[source]: Use it.
[inputs]: Use libgcrypt instead of libgcrypt-1.5.
[arguments]: Set 'ac_cv_libgcrypt=yes' in #:configure-flags.
* gnu/packages/gnupg.scm (libgcrypt-1.5): Remove variable.
2017-06-30 02:32:57 -04:00

33 lines
1.2 KiB
Diff

Fix building of Shishi with libgcrypt 1.6 and later.
Patch copied from Debian:
https://anonscm.debian.org/cgit/collab-maint/shishi.git/tree/debian/patches/fix_gcrypt_detection.diff?id=948301ae648a542a408da250755aeed58a6e3542
Description: Fix autoconf gnutls detection to also accept gcrypt 1.6.
Author: Andreas Metzler <ametzler@debian.org>
Bug-Debian: http://bugs.debian.org/753150
Origin: vendor
Forwarded: no
Last-Update: 2014-07-18
--- shishi-1.0.2.orig/gl/m4/gc.m4
+++ shishi-1.0.2/gl/m4/gc.m4
@@ -12,10 +12,12 @@ AC_DEFUN([gl_GC],
if test "$libgcrypt" != no; then
AC_LIB_HAVE_LINKFLAGS([gcrypt], [gpg-error], [
#include <gcrypt.h>
-/* GCRY_MODULE_ID_USER was added in 1.4.4 and gc-libgcrypt.c
- will fail on startup if we don't have 1.4.4 or later, so
- test for it early. */
-#if !defined GCRY_MODULE_ID_USER
+/* gc-libgcrypt.c will fail on startup if we don't have libgcrypt 1.4.4 or
+ later, test for it early. by checking for either
+ - GCRY_MODULE_ID_USER which was added in 1.4.4 and dropped in 1.6 or
+ - GCRYPT_VERSION_NUMBER which was added in 1.6.
+ */
+#if !defined GCRY_MODULE_ID_USER && !defined GCRYPT_VERSION_NUMBER
error too old libgcrypt
#endif
])