3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/vboot-utils-skip-test-workbuf.patch
Kei Kebreau b634b5c253
gnu: vboot-utils: Fix building on armhf-linux.
* gnu/packages/bootloaders.scm (vboot-utils)[source]: Add patches.
[arguments]: Conditionally add "HOST_ARCH=arm" to #:make-flags.
* gnu/packages/patches/vboot-utils-fix-format-load-address.patch,
gnu/packages/patches/vboot-utils-fix-tests-show-contents.patch,
gnu/packages/patches/vboot-utils-skip-test-workbuf.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
2019-01-03 15:40:27 -05:00

22 lines
702 B
Diff

This patch was copied from Debian.
Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16
Author: Sophie Brun <sophie@freexian.com>
Last-Update: 2015-12-03
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/tests/vb2_common_tests.c
+++ b/tests/vb2_common_tests.c
@@ -70,6 +70,11 @@ static void test_workbuf(void)
/* NOTE: There are several magic numbers below which assume that
* VB2_WORKBUF_ALIGN == 16 */
+ /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */
+ if (VB2_WORKBUF_ALIGN != 16) {
+ return;
+ }
+
/* Init */
vb2_workbuf_init(&wb, p0, 64);
TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned");