3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
Mathieu Othacehe 772ca8e4f6
gnu: supercollider: Fix build and update to 3.10.3.
* gnu/packages/patches/supercollider-boost-1.70-build-fix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/audio.scm (supercollider): Update to 3.10.3 and apply the
previous patch to fix build with boost-1.70. Remove outdated
'fix-build-with-boost-1.68 phase.
2019-09-27 10:48:54 +02:00

28 lines
1.3 KiB
Diff

Patches taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/supercollider/files/supercollider-3.10.2-boost-1.70.patch?id=a420618dc766bba0654dbe0ef67008fdc5e901c6 to fix supercollider build with boost 1.70.
diff --git a/server/supernova/sc/sc_osc_handler.cpp b/server/supernova/sc/sc_osc_handler.cpp
index 5116a1be87..96e937ec25 100644
--- a/server/supernova/sc/sc_osc_handler.cpp
+++ b/server/supernova/sc/sc_osc_handler.cpp
@@ -728,7 +728,8 @@ void sc_osc_handler::tcp_connection::handle_message() {
void sc_osc_handler::start_tcp_accept(void) {
- tcp_connection::pointer new_connection = tcp_connection::create(tcp_acceptor_.get_io_service());
+ tcp_connection::pointer new_connection =
+ tcp_connection::create((boost::asio::io_context&)tcp_acceptor_.get_executor().context());
tcp_acceptor_.async_accept(
new_connection->socket(),
diff --git a/server/supernova/utilities/utils.hpp b/server/supernova/utilities/utils.hpp
index 35b8ab5ad..a7c191f2d 100644
--- a/server/supernova/utilities/utils.hpp
+++ b/server/supernova/utilities/utils.hpp
@@ -23,6 +23,7 @@
#include <type_traits>
+#include <boost/checked_delete.hpp>
#include <boost/intrusive_ptr.hpp>
#include <boost/noncopyable.hpp>
#include <boost/detail/atomic_count.hpp>