3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/dbus-c++-threading-mutex.patch
Marius Bakke 497b2d3942
gnu: dbus-c++: Fix build with GCC 7.
* gnu/packages/patches/dbus-c++-gcc-compat.patch,
gnu/packages/patches/dbus-c++-threading-mutex.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/glib.scm (dbus-c++)[source](patches): New field.
[arguments]: End phases on #t.
2019-07-31 16:52:39 +02:00

38 lines
791 B
Diff

Description: Fix FTBFS if DBUS_HAS_RECURSIVE_MUTEX is undefined
Author: Peter Williams <peter@newton.cx>
Last-Update: 2018-01-26
Taken from Debian:
https://sources.debian.org/src/dbus-c++/0.9.0-8.1/debian/patches/07_fix_mutex_ftbfs.patch/
--- dbus-c++-0.9.0.orig/include/dbus-c++/dispatcher.h
+++ dbus-c++-0.9.0/include/dbus-c++/dispatcher.h
@@ -267,6 +267,19 @@ struct Threading
return new Mx;
}
+#ifndef DBUS_HAS_RECURSIVE_MUTEX
+ static bool mutex_free(Mutex *mx)
+ {
+ delete mx;
+ return true;
+ }
+
+ static bool mutex_lock(Mutex *mx)
+ {
+ mx->lock();
+ return true;
+ }
+#else
static void mutex_free(Mutex *mx)
{
delete mx;
@@ -276,6 +289,7 @@ struct Threading
{
mx->lock();
}
+#endif
static void mutex_unlock(Mutex *mx)
{