3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/dvd+rw-tools-add-include.patch
Thomas Danckaert 76e9845734
gnu: Add dvd+rw-tools.
* gnu/packages/cdrom.scm (dvd+rw-tools): New variable.
* gnu/packages/patches/dvd+rw-tools-add-include.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
2017-05-10 09:32:48 +02:00

15 lines
327 B
Diff

Without <limits.h>, INT_MAX is not defined.
diff --git a/transport.hxx b/transport.hxx
index 35a57a7..838add6 100644
--- a/transport.hxx
+++ b/transport.hxx
@@ -11,6 +11,7 @@
#include <stdlib.h>
#include <unistd.h>
#include <string.h>
+#include <limits.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>