3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/emacs-source-date-epoch.patch
Mark H Weaver 36a09d1853
gnu: emacs: Update to 27.1.
* gnu/packages/emacs.scm (emacs): Update to 27.1.
[source]: In snippet, use 'find-files' to find 'eshell/esh-groups.el'
if it exists, but gracefully handle its absence.
[arguments]: Add "--with-cairo" to configure-flags.  Add 'restore-emacs-pdmp'
and 'make-compressed-files-writable' phases.  Explicitly return #t from
'install-site-start' phase.
[inputs]: Add cairo, pango, harfbuzz, jansson, and gmp.  Remove imagemagick.
(emacs-next): Remove variable.
(emacs-minimal, emacs-xwidgets): Use 'package/inherit'.
[arguments]: Remove 'restore-emacs-pdmp' phase.
(emacs-no-x): Use 'package/inherit'.
[arguments]: Remove "--with-cairo" from configure-flags.  Remove
'restore-emacs-pdmp' phase.
[inputs]: Remove cairo, pango, and harfbuzz.
(emacs-no-x-toolkit): Use 'package/inherit'.
[arguments]: Remove 'restore-emacs-pdmp' phase.  Remove superfluous
quasiquote+unquote-splicing pair.
(emacs-wide-int): Use 'package/inherit'.
(guile-emacs): Use 'package/inherit'.
[arguments]: Remove "--with-cairo" from configure-flags.  Remove
'restore-emacs-pdmp' phase.
* gnu/packages/patches/emacs-ignore-empty-xim-styles.patch,
gnu/packages/patches/emacs-source-date-epoch.patch: Adapt to
apply cleanly to emacs-27.1.
* gnu/packages/patches/emacs-exec-path.patch: Replace with the previous
contents of 'emacs27-exec-path.patch', but remove the superfluous comment
about it being "like emacs-exec-path.patch, but for Emacs 27".
* gnu/packages/patches/emacs27-exec-path.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove 'emacs27-exec-path.patch'.
2020-08-28 00:13:51 -04:00

21 lines
706 B
Diff

Honor SOURCE_DATE_EPOCH variable to avoid non-determinism in generated
"autoloads" files.
--- a/lisp/emacs-lisp/autoload.el
+++ b/lisp/emacs-lisp/autoload.el
@@ -419,8 +419,12 @@
;; nil t))
;; (match-end 2))))
(insert generate-autoload-section-header)
- (prin1 `(autoloads ,autoloads ,load-name ,file ,time)
- outbuf)
+ (let* ((env (getenv "SOURCE_DATE_EPOCH"))
+ (time (if env
+ (seconds-to-time (string-to-number env))
+ time)))
+ (prin1 `(autoloads ,autoloads ,load-name ,file ,time)
+ outbuf))
(terpri outbuf)
;; Break that line at spaces, to avoid very long lines.
;; Make each sub-line into a comment.