3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/ganeti-shepherd-master-failover.patch
Marius Bakke 72a91d74ce
gnu: Add ganeti.
* gnu/packages/virtualization.scm (system->qemu-target, ganeti): New variables.
* gnu/packages/patches/ganeti-deterministic-manual.patch,
gnu/packages/patches/ganeti-disable-version-symlinks.patch,
gnu/packages/patches/ganeti-drbd-compat.patch,
gnu/packages/patches/ganeti-haskell-pythondir.patch,
gnu/packages/patches/ganeti-os-disk-size.patch,
gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch,
gnu/packages/patches/ganeti-shepherd-master-failover.patch,
gnu/packages/patches/ganeti-shepherd-support.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
2020-07-16 21:51:43 +02:00

19 lines
879 B
Diff

By default, master-failover will call "herd start ganeti-wconfd" with
extra arguments such as --force-node. That does not work with the
Shepherd, so the Guix service has a "force-start" action for this purpose.
diff --git a/lib/bootstrap.py b/lib/bootstrap.py
--- a/lib/bootstrap.py
+++ b/lib/bootstrap.py
@@ -1011,9 +1011,7 @@ def MasterFailover(no_voting=False):
try:
# Forcefully start WConfd so that we can access the configuration
- result = utils.RunCmd([pathutils.DAEMON_UTIL,
- "start", constants.WCONFD, "--force-node",
- "--no-voting", "--yes-do-it"])
+ result = utils.RunCmd(["herd", "force-start", constants.WCONFD])
if result.failed:
raise errors.OpPrereqError("Could not start the configuration daemon,"
" command %s had exitcode %s and error %s" %