3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/go-skip-gc-test.patch
Ludovic Courtès b938892551
gnu: go@1.12: Skip flaky GC test.
Fixes <https://bugs.gnu.org/37425>.

* gnu/packages/patches/go-skip-gc-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/golang.scm (go-1.12)[source]: Use it.
2019-09-16 23:45:36 +02:00

18 lines
656 B
Diff

Skip a GC test known to be flaky:
https://issues.guix.gnu.org/issue/37425
https://github.com/golang/go/issues/27636
--- go/src/runtime/gc_test.go 2019-09-16 23:10:18.200680387 +0200
+++ go/src/runtime/gc_test.go 2019-09-16 23:11:50.324360646 +0200
@@ -27,6 +27,9 @@ func TestGcSys(t *testing.T) {
if runtime.GOOS == "linux" && runtime.GOARCH == "arm64" {
t.Skip("skipping test; GOOS=linux GOARCH=arm64 https://github.com/golang/go/issues/27636")
}
+ if runtime.GOOS == "linux" {
+ t.Skip("skipping test; GOOS=linux https://issues.guix.gnu.org/issue/37425")
+ }
got := runTestProg(t, "testprog", "GCSys")
want := "OK\n"
if got != want {