3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/lcalc-lcommon-h.patch
Andreas Enge fedb9571eb
gnu: Add lcalc.
* gnu/packages/sagemath.scm (lcalc): New variable.
* gnu/packages/patches/lcalc-default-parameters-1.patch,
gnu/packages/patches/lcalc-default-parameters-2.patch,
gnu/packages/patches/lcalc-lcommon-h.patch,
gnu/packages/patches/lcalc-using-namespace-std.patch: New files.
* gnu/local.mk (dist_patch_DATA): Register patches.
2019-06-21 09:28:07 +02:00

14 lines
595 B
Diff

Patch taken from the Sage packaging system.
--- src/include/Lcommon.h 2010-01-31 15:16:45.000000000 +0000
+++ src/include/Lcommon.h 2011-03-08 21:19:11.849443238 +0000
@@ -25,7 +25,7 @@
#ifdef USE_MPFR
inline double lcalc_to_double(const double& x) { return x; }
#endif
-//inline double lcalc_to_double(const long double& x) { return x; }
+inline double lcalc_to_double(const long double& x) { return x; }
inline double lcalc_to_double(const int& x) { return x; }
inline double lcalc_to_double(const long long& x) { return x; }
inline double lcalc_to_double(const short& x) { return x; }