3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/minisat-friend-declaration.patch
Robert Smith 3b7828cc7f
gnu: Add minisat.
* gnu/packages/patches/minisat-friend-declaration.patch: New file.
* gnu/packages/patches/minisat-install.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add both files above.
* gnu/packages/maths.scm (minisat): New exported variable.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
2019-11-19 17:27:58 +01:00

26 lines
1.2 KiB
Diff

See https://groups.google.com/forum/#!topic/minisat/FCocZsC8oMQ
This seems to only be a problem with newer versions of g++, and
upstream development seems to have stopped in 2013.
diff -rupN minisat-2.2.0/core/SolverTypes.h minisat-2.2.0.patched/core/SolverTypes.h
--- a/minisat/core/SolverTypes.h 2010-07-10 17:07:36.000000000 +0100
+++ b/minisat/core/SolverTypes.h 2014-03-29 11:57:49.000000000 +0000
@@ -47,7 +47,7 @@ struct Lit {
int x;
// Use this as a constructor:
- friend Lit mkLit(Var var, bool sign = false);
+ //friend Lit mkLit(Var var, bool sign = false);
bool operator == (Lit p) const { return x == p.x; }
bool operator != (Lit p) const { return x != p.x; }
@@ -55,7 +55,7 @@ struct Lit {
};
-inline Lit mkLit (Var var, bool sign) { Lit p; p.x = var + var + (int)sign; return p; }
+inline Lit mkLit (Var var, bool sign = false) { Lit p; p.x = var + var + (int)sign; return p; }
inline Lit operator ~(Lit p) { Lit q; q.x = p.x ^ 1; return q; }
inline Lit operator ^(Lit p, bool b) { Lit q; q.x = p.x ^ (unsigned int)b; return q; }
inline bool sign (Lit p) { return p.x & 1; }