3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
Guillaume Le Vaillant c94367eaaf
gnu: sbcl-geco: Fix build.
* gnu/packages/patches/sbcl-geco-fix-organism-class.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/lisp-xyz.scm (sbcl-geco)[source]: Use it.
2020-10-31 18:01:00 +01:00

14 lines
402 B
Diff

Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
+++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
@@ -148,7 +148,7 @@
:accessor score
:initarg :score
:initform 'nil
- :type number)
+ :type (or number null))
(NORMALIZED-SCORE
:accessor normalized-score
:initarg :normalized-score