3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/datefudge-gettimeofday.patch
Ludovic Courtès eb07edabaf
gnu: datefudge: Fix compilation against libc 2.31.
* gnu/packages/patches/datefudge-gettimeofday.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/time.scm (datefudge)[source] Use it.
2020-02-17 23:01:54 +01:00

14 lines
424 B
Diff

Add the 'restrict' qualifier to match the 'gettimeofday' declaration found
in glibc 2.31.
--- datefudge-1.23/datefudge.c 2020-02-17 22:35:21.343341725 +0100
+++ datefudge-1.23/datefudge.c 2020-02-17 22:35:49.619117874 +0100
@@ -78,6 +78,6 @@
return 0;
}
-int gettimeofday(struct timeval *x, struct timezone *y) {
+int gettimeofday(struct timeval *restrict x, void *restrict y) {
return __gettimeofday(x,y);
}