3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/glibc-2.27-supported-locales.patch
Carl Dong ca3757e1c2
gnu: glibc: Add 2.27 supported locales patch.
The 'glibc-supported-locales.patch' was updated for glibc 2.29, breaking
compatibility with 2.27. Add a 2.27-specific supported locales patch.

* gnu/packages/patches/glibc-2.27-supported-locales.patch: New file.
* gnu/packages/base.scm (glibc-2.27)[source](patches): Use
'glibc-2.27-supported-locales.patch' instead.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
2019-07-08 21:20:17 -04:00

34 lines
1 KiB
Diff

This patch is taken from debian's glibc package (generate-supported.mk).
It install the localedata/SUPPORTED file of the glibc. This file lists
all the supported locales of the glibc.
diff --git a/localedata/Makefile.old b/localedata/Makefile
index 34877c0..a61d9b9 100644
--- a/localedata/Makefile.old
+++ b/localedata/Makefile
@@ -91,7 +91,8 @@ endif
# Files to install.
install-others := $(addprefix $(inst_i18ndir)/, \
$(addsuffix .gz, $(charmaps)) \
- $(locales))
+ $(locales)) \
+ $(inst_i18ndir)/SUPPORTED
tests: $(objdir)/iconvdata/gconv-modules
@@ -195,6 +196,14 @@ endif
include SUPPORTED
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
+ for locale in $(SUPPORTED-LOCALES); do \
+ [ $$locale = true ] && continue; \
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
+ done
+ $(make-target-directory)
+ $(INSTALL_DATA) LOCALES $@
+
INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
# Sometimes the whole collection of locale files should be installed.