3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/pciutils-hurd-configure.patch
Jan Nieuwenhuizen 22ee720979
gnu: pciutils: Build fixes for the Hurd.
* gnu/packages/linux.scm (kmod)[supported-systems]: Remove the Hurd.
* gnu/packages/patches/pciutils-hurd-configure.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/pciutils.scm (pciutils): Use it.
[inputs]: Include kmod only for supported systems.
2020-03-26 12:59:34 +01:00

36 lines
1.2 KiB
Diff

Add ability to detect GNU/Hurd when configuring.
Adapted from https://git.hadrons.org/cgit/debian/pkgs/pciutils.git/tree/debian/patches/00-configure-hurd.patch
From e39a3af22501234a91cf28e8c57b45f9379f9101 Mon Sep 17 00:00:00 2001
From: Damien Zammit <damien@zamaudio.com>
Date: Fri, 26 Oct 2018 09:24:04 -0400
Subject: [PATCH 2/2] Add ability to detect GNU/Hurd when configuring
---
lib/configure | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
--- a/lib/configure
+++ b/lib/configure
@@ -25,7 +25,7 @@ if [ -z "$HOST" ] ; then
proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
else
- cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
+ cpu=`uname -m | sed 's/^i.86-AT386/i386/;s/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
fi
if [ "$sys" = "DragonFly" ]
then
@@ -39,6 +39,10 @@ if [ -z "$HOST" ] ; then
then
sys=cygwin
fi
+ if [ "$sys" = "GNU" ]
+ then
+ sys=gnu
+ fi
HOST=${3:-$cpu-$sys}
fi
[ -n "$RELEASE" ] && rel="${RELEASE}"