3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/scotch-integer-declarations.patch
Eric Bavier fd3733432b
scotch: Upgrade to 6.0.6.
* gnu/packages/maths.scm (scotch): Upgrade to 6.0.6.
[source]: Remove patches that have been fixed upstream.
[arguments]: Add 'install-metis' phase.
[outputs]: New field.
(pt-scotch, pt-scotch32)[arguments]: Add 'mpi-setup' phase.  Use 'invoke'.
* gnu/packages/patches/scotch-graph-diam-64.patch,
gnu/packages/patches/scotch-graph-induce-type-64.patch,
gnu/packages/patches/scotch-test-threading.patch: Delete files.
* gnu/packages/patches/scotch-integer-declarations.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust as necessary.
2019-01-25 13:10:05 -06:00

38 lines
1.1 KiB
Diff

diff --git a/src/libscotch/library.h b/src/libscotch/library.h
index 1891c19..ecc0533 100644
--- a/src/libscotch/library.h
+++ b/src/libscotch/library.h
@@ -67,6 +67,8 @@
/*+ Integer type. +*/
+#include <stdint.h>
+
typedef DUMMYIDX SCOTCH_Idx;
typedef DUMMYINT SCOTCH_Num;
diff --git a/src/libscotchmetis/library_metis.h b/src/libscotchmetis/library_metis.h
index e6767e1..04e71c3 100644
--- a/src/libscotchmetis/library_metis.h
+++ b/src/libscotchmetis/library_metis.h
@@ -99,6 +99,7 @@ typedef enum {
*/
#ifndef SCOTCH_H /* In case "scotch.h" not included before */
+#include <stdint.h>
typedef DUMMYINT SCOTCH_Num;
#endif /* SCOTCH_H */
diff --git a/src/libscotchmetis/library_parmetis.h b/src/libscotchmetis/library_parmetis.h
index 6d2f0b0..3c803fc 100644
--- a/src/libscotchmetis/library_parmetis.h
+++ b/src/libscotchmetis/library_parmetis.h
@@ -106,6 +106,7 @@ typedef enum {
*/
#ifndef SCOTCH_H /* In case "scotch.h" not included before */
+#include <stdint.h>
typedef DUMMYINT SCOTCH_Num;
#endif /* SCOTCH_H */