3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/sdl-libx11-1.6.patch
Mark H Weaver 9cb3036f0d gnu: sdl: Fix incompatibility with libx11-1.6.
* gnu/packages/patches/sdl-libx11-1.6.patch: New file
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/sdl.scm (sdl): Add patch.
2014-12-26 00:34:44 -05:00

14 lines
600 B
Diff

Update _XData32 declaration in SDL_x11sym.h to match that of libx11 1.6.
--- SDL-1.2.15/src/video/x11/SDL_x11sym.h.~1~ 2012-01-19 01:30:06.000000000 -0500
+++ SDL-1.2.15/src/video/x11/SDL_x11sym.h 2014-12-26 00:22:36.445067694 -0500
@@ -165,7 +165,7 @@
*/
#ifdef LONG64
SDL_X11_MODULE(IO_32BIT)
-SDL_X11_SYM(int,_XData32,(Display *dpy,register long *data,unsigned len),(dpy,data,len),return)
+SDL_X11_SYM(int,_XData32,(Display *dpy,register _Xconst long *data,unsigned len),(dpy,data,len),return)
SDL_X11_SYM(void,_XRead32,(Display *dpy,register long *data,long len),(dpy,data,len),)
#endif