3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/hash-extender-test-suite.patch
Jakub Kądziołka bbeb710de7
gnu: Add hash-extender.
* gnu/packages/crypto.scm (hash-extender): New variable.
* gnu/packages/patches/hash-extender-test-suite.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register the new file.
2020-03-21 12:56:11 +01:00

13 lines
500 B
Diff

Make the test suite exit with a non-zero exit code if some tests failed.
Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
--- a/test.c
+++ b/test.c
@@ -79,5 +79,9 @@ void test_report(void)
printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
printf("--------------------------------------------------------------------------------\n");
}
+
+ if (tests_passed != tests_run) {
+ exit(1);
+ }
}