3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/fontconfig-hurd-path-max.patch
Jan Nieuwenhuizen 9dd9e8fabf
gnu: fontconfig: Build fix for the Hurd.
* gnu/packages/patches/fontconfig-hurd-path-max.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/fontutils.scm (fontconfig): Use it.
2020-03-26 12:59:33 +01:00

18 lines
482 B
Diff

Avoid usage of PATH_MAX.
Taken from https://salsa.debian.org/freedesktop-team/fontconfig/-/blob/master/debian/patches/path_max.patch
Index: fontconfig-2.13.1/src/fccfg.c
===================================================================
--- fontconfig-2.13.1.orig/src/fccfg.c
+++ fontconfig-2.13.1/src/fccfg.c
@@ -2231,7 +2231,7 @@ FcConfigRealFilename (FcConfig *config,
if (n)
{
- FcChar8 buf[PATH_MAX];
+ FcChar8 buf[FC_PATH_MAX];
ssize_t len;
if (sysroot)