3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/kobodeluxe-const-charp-conversion.patch
Stephen Webber a56145e1fa
gnu: Add kobodeluxe.
* gnu/packages/games.scm (kobodeluxe): New variable.
* gnu/packages/patches/kobodeluxe-paths.patch: New file.
* gnu/packages/patches/kobodeluxe-enemies-pipe-decl.patch: New file.
* gnu/packages/patches/kobodeluxe-const-charp-conversion.patch: New file.
* gnu/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch: New file.
* gnu/packages/patches/kobodeluxe-midicon-segmentation-fault.patch: New file.
* gnu/packages/patches/kobodeluxe-graphics-window-signed-char.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
2016-10-18 20:23:03 -05:00

18 lines
675 B
Diff

Description: Avoid compilation error with gcc-4.4.
"const char* -> char*" conversion is fatal in that version
Origin: vendor, https://bugs.launchpad.net/ubuntu/+source/kobodeluxe/+bug/461373
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/kobodeluxe/+bug/461373
Bug-Debian: http://bugs.debian.org/552548
Forwarded: http://www.freelists.org/post/olofsonprojects/kobodlpatch-compile-error-in-windowcpp-with-g44
--- a/graphics/window.cpp
+++ b/graphics/window.cpp
@@ -398,7 +398,7 @@ void window_t::center_token_fxp(int _x,
*/
if(token)
{
- char *tok = strchr(txt, token);
+ const char *tok = strchr(txt, token);
if(tok)
tokpos = tok-txt;
else