3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/plotutils-spline-test.patch
Maxim Cournoyer 2bd84c50ff
gnu: plotutils: Fix build on non-x86_64 architectures.
* gnu/packages/patches/plotutils-spline-test.patch: Add patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/plotutils.scm (plotutils)[patches]: Apply it.
2020-07-27 00:02:10 -04:00

35 lines
1.1 KiB
Diff

Description: Work around i386 testsuite error
Author: Andreas Metzler <ametzler@debian.org>
Origin: vendor
Bug: http://lists.gnu.org/archive/html/bug-plotutils/2017-02/msg00001.html
Bug-Debian: https://bugs.debian.org/856134
Forwarded: http://lists.gnu.org/archive/html/bug-plotutils/2017-02/msg00002.html
Last-Update: 2017-02-25
--- a/test/spline.test
+++ b/test/spline.test
@@ -3,12 +3,21 @@
echo 0 1 0.5 0.75 -0.25 0 | ../spline/spline -a -T 1 -n 120 \
--precision 5 -p >spline.out
+# Work around testsuite error
+# http://lists.gnu.org/archive/html/bug-plotutils/2016-04/msg00000.html
+#
# work around line end problems in installations with DJGPP under DOS
-tr -d '\015' < spline.out > spline.dos
+tr -d '\015' < spline.out \
+ | head -n 120 | tail -n 119 \
+ > spline.dos
-if cmp -s $SRCDIR/spline.xout spline.dos
+# cannot patch spline.xout, it is used as input for graph.test.
+head -n 120 $SRCDIR/spline.xout | tail -n 119 > spline.xout.4comp
+
+if cmp -s spline.xout.4comp spline.dos
then retval=0;
else retval=1;
fi;
+rm -f spline.xout.4comp
exit $retval