3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch
Efraim Flashner b3d20b8280
gnu: vorbis-tools: Fix CVE-2014-9638, CVE-2014-9639, CVE-2014-9640.
* gnu/packages/xiph.scm (vorbis-tools)[source]: Add patches.
* gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch,
gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch: New variables.
* gnu/local.mk (dist_patch_DATA): Add them.
2016-05-30 06:42:02 +03:00

30 lines
1.4 KiB
Diff

Index: vorbis-tools/oggenc/oggenc.c
===================================================================
--- vorbis-tools/oggenc/oggenc.c (revision 19116)
+++ vorbis-tools/oggenc/oggenc.c (revision 19117)
@@ -98,4 +98,6 @@
0,0,0.f,
0, 0, 0, 0, 0};
+ input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
+ N_("RAW file reader")};
int i;
@@ -240,6 +242,4 @@
if(opt.rawmode)
{
- input_format raw_format = {NULL, 0, raw_open, wav_close, "raw",
- N_("RAW file reader")};
enc_opts.rate=opt.raw_samplerate;
Index: vorbis-tools/oggenc/skeleton.h
===================================================================
--- vorbis-tools/oggenc/skeleton.h (revision 19116)
+++ vorbis-tools/oggenc/skeleton.h (revision 19117)
@@ -42,5 +42,5 @@
ogg_int64_t start_granule; /* start granule value */
ogg_uint32_t preroll; /* preroll */
- unsigned char granule_shift; // a 8-bit field /* 1 byte value holding the granule shift */
+ unsigned char granule_shift; /* 1 byte value holding the granule shift */
char *message_header_fields; /* holds all the message header fields */
/* current total size of the message header fields, for realloc purpose, initially zero */