mirror of
git://git.savannah.gnu.org/guix.git
synced 2023-12-14 03:33:07 +01:00
3485984a09
* gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch, gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch: New files. * gnu/packages/llvm.scm (clang-runtime-3.7, llvm-3.7, llvm-3.8): Use patches. * gnu/local.mk: Register patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
16 lines
595 B
Diff
16 lines
595 B
Diff
Patch based on changes from
|
|
https://github.com/llvm/llvm-project/commit/c1fde4fa943fd03a3d40bc5d32b9e0045fd29208
|
|
|
|
diff --git a/lib/sanitizer_common/scripts/gen_dynamic_list.py b/lib/sanitizer_common/scripts/gen_dynamic_list.py
|
|
index 5ea2ca1..d7bc287 100755
|
|
--- a/lib/sanitizer_common/scripts/gen_dynamic_list.py
|
|
+++ b/lib/sanitizer_common/scripts/gen_dynamic_list.py
|
|
@@ -100,7 +100,7 @@ def main(argv):
|
|
print('global:')
|
|
result.sort()
|
|
for f in result:
|
|
- print(' ' + f.encode('utf-8') + ';')
|
|
+ print(u' %s;' % f)
|
|
if args.version_list:
|
|
print('local:')
|
|
print(' *;')
|