3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/beets-werkzeug-compat.patch
Marius Bakke e76cbdcd90
gnu: beets: Fix build with newer Werkzeug.
* gnu/packages/patches/beets-werkzeug-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/music.scm (beets)[source](patches): New field.
2020-03-16 15:45:34 +01:00

19 lines
535 B
Diff

Be compatible with python-werkzeug 1.0.0.
Taken from upstream:
https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
index f53fb3a954..21ff5d94ed 100644
--- a/beetsplug/web/__init__.py
+++ b/beetsplug/web/__init__.py
@@ -169,7 +169,7 @@ def to_python(self, value):
return ids
def to_url(self, value):
- return ','.join(value)
+ return ','.join(str(v) for v in value)
class QueryConverter(PathConverter):