3
5
Fork 0
mirror of git://git.savannah.gnu.org/guix.git synced 2023-12-14 03:33:07 +01:00
guix/gnu/packages/patches/fasthenry-spSolve.patch
Federico Beffa 23bae7bb86 gnu: Add fasthenry.
* gnu/packages/engineering.scm (fasthenry): New variable.
* gnu/packages/patches/fasthenry-spAllocate.patch,
  gnu/packages/patches/fasthenry-spBuild.patch,
  gnu/packages/patches/fasthenry-spFactor.patch,
  gnu/packages/patches/fasthenry-spSolve.patch,
  gnu/packages/patches/fasthenry-spUtils.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
2015-08-01 12:29:37 +02:00

13 lines
322 B
Diff
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

Add forward declarations.
--- fasthenry-3.0/src/fasthenry/sparse/spSolve.c.orig 2015-07-22 12:06:20.502771958 +0200
+++ fasthenry-3.0/src/fasthenry/sparse/spSolve.c 2015-07-22 12:12:03.822798513 +0200
@@ -95,6 +95,7 @@
#include "spDefs.h"
+static void SolveComplexMatrix( MatrixPtr, RealVector, RealVector );